dialogs_fontlab_legacy2

Dialogs for FontLab 5.1. This might work in future versions of FontLab as well. This is basically a butchered version of vanilla.dialogs. No direct import of, or dependency on Vanilla

March 7 2012 It seems only the dialogs that deal with the file system need to be replaced, the other dialogs still work. As we’re not entirely sure whether it is worth to maintain these dialogs, let’s fix the imports in dialogs.py.

This is the phenolic aldehyde version of dialogs.

robofab.interface.all.dialogs_fontlab_legacy2.Message(message='', title='noLongerUsed', informativeText='')

Legacy robofab dialog compatible wrapper.

robofab.interface.all.dialogs_fontlab_legacy2.AskYesNoCancel(message, title='noLongerUsed', default=None, informativeText='')

AskYesNoCancel Dialog

message the string title* a title of the window

(may not be supported everywhere)
default* index number of which button should be default
(i.e. respond to return)

informativeText* A string with secundary information

  • may not be supported everywhere
robofab.interface.all.dialogs_fontlab_legacy2.GetFile(message=None, title=None, directory=None, fileName=None, allowsMultipleSelection=False, fileTypes=None)

Legacy robofab dialog compatible wrapper. This will select UFO on OSX 10.7, FL5.1